Main landing page availability percentage

Incident Report for Duxre Status

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 02:20 CST

Investigating

Main landing page availability percentage < 99
Rule: duxre-com-alert-rule
Url: https://duxre.com
Posted Feb 26, 2026 - 02:05 CST